Go Back   Scionlife.com » Regional » Regional - Pacific Mid
Sign in using an external account
Register Forgot Password?

Regional - Pacific Mid CA, NV

Reply
 
 
 
Old 02-22-2012, 01:48 AM   #1
Junior Member
Dorison 27/M

 
Join Date: Feb 2012
Location: East Bay Area, CA
iTrader: (0)
Smile Vsc, trac off, check engine lights!!!

I own a 2006 Scion XB. .
Camo Mica Green
Completely STOCK

I recently bought this car used from the original owner, with 153k miles on it. (I know, I know that's a lot). . . I can tell that the car was never really cared for. He was a smoker, the inside was trashed and completely dirty. I have had to do some major detailing in order to get this this even looking halfway descent.

ANY WHO!! The day I bought it I went for a drive to enjoy the new car and the (CHECK ENGINE, VSC, Trac OFF) lights came on in that order, they would flash on and off and then the car lost a lot of power and was shaking bad. SOOOoo, I took it to my mechanic and he was surprised that it had NEVER had a tune up, and that all the fluids were bad and needed flushing. My ignition coil was burnt out and a few sensor's were bad. It needed a alignment and new back brakes. Out the door the next day I dropped $444 and change, to get it running well again, Then A week later i went back to get the alignment and new brakes and dropped another $214..total now coming to $658. I was really hoping that this car wouldn't have many problems. but so far that seems to not be the case. .

I don't blame the car as much as I blame the previous owner for neglecting the car as badly as he had.

I just recently took the family out for a drive and my (Check Engine, Trac Off, VSC) lights came on again. . I was low on fuel, so I got some gas and noticed that the cap was loose. I will admit that I did put a little to much gas in there when I filled it, but the lights went off still. .

flash forward to yesterday, The Three lights came back on, so I bought a new gas cap, hoping that would help, and they stayed on. I took it to PeP BoYs for a check engine light thingy, and the code was (P0012), my mechanic today (2/21/12) Told me there was a TSB for my cam sprocket!! and that I would also need a new gasket, so out the door im looking at $407 to get that fixed.

At that point im really not happy with the car thinking, "REALLY, WHY ME", when my mech said, How dose the car drive. . The car drive's GREAT still and those lights are intermittently coming and going. NO loss in power and still getting great gas mileage. he says to come back when the car isnt running so well and he will fix the sprocket. and to keep an eye on the lights, because they might go off and stay off if it was something else...

I get in my car to leave and I notice the Lights are off and haven't come back on yet. . . WHAT THE HECK! ! don't get me wrong, I'm happy, but WTF!!

I have read SOOO many postings about what people have done to there cars before the lights and after what they did to fix there car. Nobody was really in my boat and the postings were PAGES deep. so I thought I would post my problems and see if any one would have any suggestions.

Also, The windshield has a snake like crack in the top middle area, and the AC blower is burnt out, not the blower motor regulator, I was really hoping that was it, since I Found out how cheap and easy that fix is. The Back right tail light is cracked and there are dents/scratches here and there. . It didn't have the keys for keyless entry, so I bought a new system all together. the driver door is missing the weather stripping and it needed new hubs, oil change, and front wipers. .

Needless to say, This car has cost A LOT to get it back to normal, I kinda feel like It has been to much to be where it is now, but I love the car A LOT. It has been one of the coolest/newer cars I have owned. and I have always wanted one since they came out..

none related/ I used to drive a 92 Nissan 240sx and was into drifting kinda hard for years. . I was on the forums all the time, so I'm really looking forward to participating with this new car that obviously has a big online forum presence. . . .


Thanks for any help,

MIKE D.
Dorison is offline   Reply With Quote
Old 02-25-2012, 05:57 AM   #2
Senior Member
5 Year Member
SL Member
 
VIP_CAMO's Avatar
VIP_CAMO 33/M

 
Join Date: Aug 2006
Location: SJ408-KC816-KS913
iTrader: (0)
Default

There is a trick you can do to reset the trace,vsc lights,But i can't remember what number in the port it was ill see if i can find you the link..Basically you want to get a paper clip and put one end in socket? and the other in socket? and that will reset it for you.I will pm you when i get more info
__________________
Graphic Design Heroes! Call me Captain Type Caster. I’ve fought off “The Evil Comic Sans” for year's but it seems “Dr. Extreme Untalent” keeps bringing him back. I must find a way to defeat this evil creature.
VIP_CAMO is offline   Reply With Quote
Old 03-06-2012, 06:21 PM   #3
Junior Member
Dorison 27/M

 
Join Date: Feb 2012
Location: East Bay Area, CA
iTrader: (0)
Default

my lights are coming and going, they are off more then there on so I feel like it might be what my mechanic said about the cam sprocket. Plus I can tell sometimes it has less power then normal. .

after that $407 mech bill next will be my AC/Heater motor blower/ windshield/ back lights/ and finally that dumb latch handle for the back gate that broke off and is now dangling around. . I swear if i get a ticket for that....
Dorison is offline   Reply With Quote
Old 03-08-2012, 04:43 AM   #4
Senior Member
10 Year Member
5 Year Member
SL Member
 
funalan's Avatar
funalan 40/M

 
Join Date: Apr 2004
Location: Fremont
iTrader: (0)
Send a message via Yahoo to funalan
Default

you pull you EFI fuse under the hood fuse box for 10 min then put it back in and you should clean you AIR flow sensor on you air intake
__________________
A.K.A "EFFINJOE "
funalan is offline   Reply With Quote
Old 03-08-2012, 06:00 PM   #5
Junior Member
ma14 30
 
Join Date: Mar 2012
iTrader: (0)
Default

I also own a 2006 Scion Xb and have had it since it was brand new at the end of 2005 and it now has 160K on it. Other than a few normal ware things it has been a good little car That was until this morning when it lost power and the (Check Engine, Trac Off, VSC) lights came on and would not run over 40mph. I limped into town and into a Firestone where it is now waiting on the part.



Just so you don’t feel so bad Firestone is charging me $418.20 for the part $427 for labor $99.50 for diagnostics and finally $14 more for a consultation fee.



Anyone else who has these lights coming on intermittently may want to shop around before you are forced to have repairs done and defiantly avoid Firestone if you can.


It makes me mad as hell to know it will cost me more than $500 more to have the same cam sprocket problem fixed at Firestone!



I will hitchhike before I do business with Firestone again.


Mike Allen
ma14 is offline   Reply With Quote
Old 08-10-2013, 01:01 AM   #6
Junior Member
Nursenorah 33
 
Join Date: Aug 2013
iTrader: (0)
Default

Soooo... I have a Scion XB 09' it's my Ninja. I don't take as good care if it as I would like... But Yeah... The past 2 days when I started my car, it didnt seem like it started as fast as it normally does. I take it to where I bought my battery. They test it... It was a bad battery. YES!! I get it replaced. Put it in reverse and my passenger seat starts shaking like crazy. I put it in park... Wait a minute, try again... Same thing. The workers come help me.. They have no idea what's going on... I fuel it up. Drive away and the more I drive it... It gets back to normal... 2 hours after... My VSC, Trac off and Check Engine light come on... Wtf?! I know I need new brakes but my mechanic said it wasn't urgent. Sucks.
Nursenorah is offline   Reply With Quote
Old 08-22-2013, 07:46 PM   #7
Senior Member
5 Year Member
SL Member
Scinergy
XBbarkeeper 44/M

 
Join Date: Sep 2004
Location: Hayward, Ca.
iTrader: (0)
DipStique
Default

To be honest i had those same lights and loss of power intermittently it turned out to be my cat. I had to go to 6 different mechanics but finally a friend at Toyota 101 where i had worked a while back fixed it for me. I replaced the cat, reset my whole system and haven't had any problems since! Good luck!
__________________
Life is too short, Love every minute of it!

Build the Best, Include the Rest!!!
XBbarkeeper is offline   Reply With Quote
Old 08-29-2013, 03:00 AM   #8
Senior Member
5 Year Member
SL Member
 
VIP_CAMO's Avatar
VIP_CAMO 33/M

 
Join Date: Aug 2006
Location: SJ408-KC816-KS913
iTrader: (0)
Default

Quote:
Originally Posted by Nursenorah View Post
Soooo... I have a Scion XB 09' it's my Ninja. I don't take as good care if it as I would like... But Yeah... The past 2 days when I started my car, it didnt seem like it started as fast as it normally does. I take it to where I bought my battery. They test it... It was a bad battery. YES!! I get it replaced. Put it in reverse and my passenger seat starts shaking like crazy. I put it in park... Wait a minute, try again... Same thing. The workers come help me.. They have no idea what's going on... I fuel it up. Drive away and the more I drive it... It gets back to normal... 2 hours after... My VSC, Trac off and Check Engine light come on... Wtf?! I know I need new brakes but my mechanic said it wasn't urgent. Sucks.
Why would you bump a old post? Why not just start your own thread as his refers to the first gen xb..
__________________
Graphic Design Heroes! Call me Captain Type Caster. I’ve fought off “The Evil Comic Sans” for year's but it seems “Dr. Extreme Untalent” keeps bringing him back. I must find a way to defeat this evil creature.
VIP_CAMO is offline   Reply With Quote
Old 09-05-2013, 10:33 PM   #9
Senior Member
5 Year Member
SL Member
 
hsoj_v's Avatar
hsoj_v 28/M
 
Join Date: Mar 2006
iTrader: (0)
Send a message via AIM to hsoj_v
Default

I had these lights on for almost 2 years. The first time they ever appeared was when I just put on Tanabe lowering springs. I was driving in some what of a rainy day and they just lit. I've heard so many different stories from clubxb, bbsquad, and here scionlife. From Alignment issues, o2 sensors, VVT-i modules, EVAP canisters, etc. I've got around 69,700 miles on it now and its a 2006. I've driven the vehicle from Northern Cali to Las Vegas about 8 or 9 times now, to work and school. This car is Daily Driven.

All in all, just last night I drove from San Jose, to Sacramento and on the way back I noticed the lights were completely off. I thought it was just temporary but then again I drove to work and home from work with the lights not coming on again.

And just now after passing 70k miles the lights are on again.

Just the weirdest issue I've ever had with a car so far.
__________________
2006 Scion xB RS3 #1905

Last edited by hsoj_v; 10-18-2013 at 04:40 PM. Reason: update
hsoj_v is offline   Reply With Quote
Old 10-24-2013, 02:03 AM   #10
Junior Member
john2049 27
 
Join Date: Oct 2013
iTrader: (0)
Default any updates?

Hey everyone,
I have the same issue with my 2006 scion xb. Just started today. Seems to run with slightly less power, hard to tell though. Anyone every nail down what was happening when these three lights go on at once?

Thanks in advance

-john
john2049 is offline   Reply With Quote
Old 11-20-2013, 11:47 AM   #11
Junior Member
dbphiladelphia 36
 
Join Date: Nov 2013
iTrader: (0)
Default

Same lights: VSC, Trac Off, and Check Engine. 2004 xB- 183K miles. Happened at about 70 mph with the tach at about 3200 (I *hate* that the engine revs that high at normal highway speeds!). It felt like I lost my 4th gear. Started reving up to 4500-5000 while losing speed. Ended up being a burnt out coil, causing me to run on 3 cylinders. $200 form parts and labor. Not bad, except that I had just spent about a grand on all new tires, brake pads and new drums, and a new front wheel bearing hub assembly. The rear needs replacing as well, but at $300/$350, that's gonna have to wait a bit...
dbphiladelphia is offline   Reply With Quote
Old 12-10-2013, 11:07 AM   #12
Junior Member
workingdee 37
 
Join Date: Dec 2013
iTrader: (0)
Default

I have a 2006 XB with approximately 140,000 miles on it. This August I replaced the catalytic converter and the warning lights went off. I did notice that it didn't quite feel the same after the cat was replaced but it drove ok. After about a month I notice the occasional brief shaking. It only would happen for maybe 3 seconds and then the rest of the ride would be fine. Last week I topped off the oil (it had gotten very low) and hoped it would be ok.

This morning on my way in to work I was going up a hile with about a 45 degree incline and it shook briefly and then the VSC Trac Off Check Engine warning lights came on. Is it possible that the oil is the issue? Or could it be the cat converter still causing problems? My mechanic told me that I might need to replace my breaks this month. Any info would be greatly appreciated. Thanks!
workingdee is offline   Reply With Quote
Old 12-22-2013, 10:07 PM   #13
Member
5 Year Member
SL Member
 
Jesboyhere's Avatar
Jesboyhere 29/M
 
Join Date: Nov 2004
Location: round rock
iTrader: (1)
Send a message via AIM to Jesboyhere
Default

the trac and vsc lights always come on when the check engine light comes on
Jesboyhere is offline   Reply With Quote
Old 01-03-2014, 06:34 PM   #14
Junior Member
Sheerah 54
 
Join Date: Jan 2014
iTrader: (0)
Default

Quote:
Originally Posted by workingdee View Post
This morning on my way in to work I was going up a hile with about a 45 degree incline and it shook briefly and then the VSC Trac Off Check Engine warning lights came on. Is it possible that the oil is the issue? Or could it be the cat converter still causing problems? My mechanic told me that I might need to replace my breaks this month. Any info would be greatly appreciated. Thanks!
Hi all. New here. I found this site through a google search for VSC light.
My experience this morning is similar to Dee's. I park in my garage, but it's a chilly morning. I warmed the car up a few minutes before leaving for work. I felt the car kind of lose power and shake a bit and I noticed at least two of the lights. I pulled over for a minute and waited, not quite sure what to do. The lights went off and I drove my 20 miles into work, albeit nervously.

My car is an 2008 xB with 84K miles. I just had 4 new tires put on and I thought this might be related to that in some way. But reading here, maybe not. I'll go check my gas cap at lunch time, but assuming that's not the issue, and not being very automobile savvy, it sounds like if the problem persists I'll have to take it to the dealer (ugh $$$) for a diagnostics check.
Sheerah is offline   Reply With Quote
Old 01-03-2014, 07:12 PM   #15
Senior Member
SL Member
 
criminaltc's Avatar
criminaltc 24

 
Join Date: Jul 2010
Location: 608
iTrader: (0)
Default

Sheerah. If you don't want to spend the $90 for Toyota to tell you exactly what the problem is, then go to Autozone or one alike, and have them pull the code for you. Then you can either call Toyota or look online for what the code pertains to and go from there. Otherwise, I'd relate this to your tire change. If you have a check engine, then maybe I wouldn't, but if it's only the other lights, then I would. Let us know what you find.
__________________
...and remember kids, wheel gap is bad for your health.
criminaltc is offline   Reply With Quote
Old 01-03-2014, 10:22 PM   #16
Junior Member
Sheerah 54
 
Join Date: Jan 2014
iTrader: (0)
Default

Quote:
Originally Posted by criminaltc View Post
Sheerah. If you don't want to spend the $90 for Toyota to tell you exactly what the problem is, then go to Autozone or one alike, and have them pull the code for you. Then you can either call Toyota or look online for what the code pertains to and go from there. Otherwise, I'd relate this to your tire change. If you have a check engine, then maybe I wouldn't, but if it's only the other lights, then I would. Let us know what you find.
Thanks Criminal! I have an Autozone near me so I'll do that. I know at least two of the lights came on. I'm also going to swing by American tire and have them check things out.

Just to make sure I understand, only if the check engine light came on will I have a code to pull. Is that correct?
Sheerah is offline   Reply With Quote
Old 01-06-2014, 01:24 PM   #17
Senior Member
SL Member
 
criminaltc's Avatar
criminaltc 24

 
Join Date: Jul 2010
Location: 608
iTrader: (0)
Default

Correct. But with any code, Toyota could figure out what the problem is, not AutoZone. It will just cost you $90 or so.
__________________
...and remember kids, wheel gap is bad for your health.
criminaltc is offline   Reply With Quote
Old 01-07-2014, 07:20 PM   #18
Junior Member
Sheerah 54
 
Join Date: Jan 2014
iTrader: (0)
Default

Well, on Friday I unscrewed the gas cap and screwed it back on. So far the problem hasn't repeated itself.

I was at a brunch on Sunday and a mechanic was there. He is suspicious that just replacing the gas cap will solve the problem. I have to get some recall work done. The window master switch on the driver's side needs to be replaced. Apparently the darned thing could just catch on fire. I'm having that work done on the 20th, so I have 1.5 weeks for the problem to resurface. I am driving up to Lake Tahoe this weekend so we shall see.
Sheerah is offline   Reply With Quote
Old 01-07-2014, 07:29 PM   #19
Senior Member
SL Member
 
criminaltc's Avatar
criminaltc 24

 
Join Date: Jul 2010
Location: 608
iTrader: (0)
Default

Good report. Keep us posted!
__________________
...and remember kids, wheel gap is bad for your health.
criminaltc is offline   Reply With Quote
Old 02-21-2014, 12:00 AM   #20
Junior Member
Sunshine1964 50
 
Join Date: Feb 2014
iTrader: (0)
Default VSC Trac Off Light on!!

Forgive me if I offend anyone here, as you may all know this already but us Scion XB owners have a Trac button inside the car! I freaked to day when the VSC Trac Off light came on along with my engine light! I was just toodling down the road....I called a dealer...(not a scion dealer but dealer where bought car)...he had no clue....posts on the net were not helpful and scaring me that I had bought a lemon! Well my ex told me to go inside my car and just "push the TRAC button". I didnt even know I had such a thing! It worked and all back to normal. Guess Traction control goes off when it's cold and wet outside...I had no clue. So if you all know this, great but I didn't and it was a quick fix. Interesting a mechanic at a huge dealership had no clue what it was! Hope this helps at least one person keep their sanity.
Sunshine1964 is offline   Reply With Quote
Old 02-21-2014, 12:00 AM
Scionlife.com
Scion TC



Paid Advertisement
 
 
 
Reply


Tags
04, 2005, 2006, check, engine, light, lights, p0012, scion, trac, track, turn, vsc, vscjnbv, xb


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT. The time now is 01:29 PM.
Advertising - Privacy Statement - Terms of Service - Jobs
vBulletin® v3.8.7, Copyright ©2000-2014, vBulletin Solutions, Inc.
SEO by vBSEO ©2011, Crawlability, Inc.


Forums Backup with Admin Control Panel