Notices
Scion tC 1G Aero & Exterior Aero parts and exterior dress items...

Ipod/Sun roof issue 2006 tC

Old 04-25-2012, 02:48 AM
  #1  
Junior Member
5 Year Member
Thread Starter
 
Join Date: Apr 2012
Posts: 10
Default Ipod/Sun roof issue 2006 tC

I have searched and searched and have yet to find a solution for either.

First off I am a new proud owner of a 2006 Scion tC. I got it for a really good price and therefore it had a few issues.

One issue is I have the AUX plug in on the inside of my arm rest and when I plug the iPod in the noise only come from my front drivers speaker and is horrible quality. Doesn't play the whole things kinda skips through words.
I have searched and found I may need a different AUX cord but I have tried 3 that all work on my Alpine in another car.

My other issue is the sun roof. It opens just fine, but will not close. When I push the close button it does nothing at all. I spent 20 minutes pushing the button and trying to pull the thing and push the deflector around till it finally came closed.
Is this a known issue? What do you guys suggest I do? I want to be able to use the sun roof considering its summer time and car looks awesome with it open.

Again I'm sorry if this has been discussed but I have searched and found no good solution for either.


*Moved to Correct Forum by Administrator

Sticky Where to Post Your Question

Sticky How To Advanced Search SL (Scion Life)

______________________________

Last edited by MR_LUV; 01-08-2019 at 07:19 PM. Reason: Moved to Correct Forum by Administrator
EATJ is offline  
Old 04-25-2012, 02:53 AM
  #2  
Senior Member
10 Year Member
5 Year Member
Scikotics
SL Member

 
engifineer's Avatar
 
Join Date: Nov 2004
Location: Minneapolis, MN
Posts: 9,730
Default

Do you mean it starts to close, then opens again? If so, you likely need to make sure the pivot points on the wind deflector arms move freely and are lubricated. Also lubricate the top of the arms on the deflector (use something like silicone spray or graphite). The sunroof slides on those, pushing the arms down, which is what pushes the deflector down. If it is dry and not lubricated or the pivots are dirty and binding up, it will cause enough resistance to trigger the jam protection on the roof. You also may need to blow out the tracks and make sure they are free of junk and lubricated.
engifineer is offline  
Old 04-25-2012, 02:58 AM
  #3  
Junior Member
5 Year Member
Thread Starter
 
Join Date: Apr 2012
Posts: 10
Default

Originally Posted by engifineer View Post
Do you mean it starts to close, then opens again? If so, you likely need to make sure the pivot points on the wind deflector arms move freely and are lubricated. Also lubricate the top of the arms on the deflector (use something like silicone spray or graphite). The sunroof slides on those, pushing the arms down, which is what pushes the deflector down. If it is dry and not lubricated or the pivots are dirty and binding up, it will cause enough resistance to trigger the jam protection on the roof. You also may need to blow out the tracks and make sure they are free of junk and lubricated.

No I mean it does nothing period. It opens fine. But when I push the close button it does nothing.
EATJ is offline  
Old 04-25-2012, 05:34 AM
  #4  
Senior Member
5 Year Member
SL Member

 
Join Date: Mar 2011
Location: Hackettstown, NJ
Posts: 305
Default

I have an issue with my sunroof where I have to push really hard on the button or push it multiple times to make it do anything, is that similar to what yours does?

The thing with your aux, its probably the port that's bad. have you tried the actual ipod cable? did the car come with one?
rand0mher0 is offline  
Old 04-25-2012, 11:47 AM
  #5  
Junior Member
5 Year Member
Thread Starter
 
Join Date: Apr 2012
Posts: 10
Default

Originally Posted by rand0mher0 View Post
I have an issue with my sunroof where I have to push really hard on the button or push it multiple times to make it do anything, is that similar to what yours does?

The thing with your aux, its probably the port that's bad. have you tried the actual ipod cable? did the car come with one?
UPDATE!!!! I tried it on the way home from work on the open highway and It worked the way it was suppose to. I would push the button it would open some of the way, then again and it would open even more and etc till it was all the way open. Then I would push to close it (while driving) and it would close a little bit (about a fourth) of the way at a time. Then when I got home I would try and close it and it would go almost all the way then open back up. It did this till I held the close button and push the deflector down.

Even when I pressed hard on the button it didnt come. I cant remember what actually finally made it move. It was a combination of lots of button pushing, hard button pushing, trying to mess with deflector and the actual sunroof then it finally came.


I dont have the cord that the car came with im just using a basic one i bought at best buy. I have read that they need a specific cord but I have also read the some people bought 5 dollar ones at the store that works.

Last edited by EATJ; 04-25-2012 at 09:54 PM.
EATJ is offline  
Old 01-08-2019, 06:01 PM
  #6  
Junior Member
SL Member
 
Join Date: Jan 2019
Posts: 6
Default

Originally Posted by EATJ View Post
UPDATE!!!! I tried it on the way home from work on the open highway and It worked the way it was suppose to. I would push the button it would open some of the way, then again and it would open even more and etc till it was all the way open. Then I would push to close it (while driving) and it would close a little bit (about a fourth) of the way at a time. Then when I got home I would try and close it and it would go almost all the way then open back up. It did this till I held the close button and push the deflector down.

Even when I pressed hard on the button it didnt come. I cant remember what actually finally made it move. It was a combination of lots of button pushing, hard button pushing, trying to mess with deflector and the actual sunroof then it finally came.


I dont have the cord that the car came with im just using a basic one i bought at best buy. I have read that they need a specific cord but I have also read the some people bought 5 dollar ones at the store that works.

I believe if you look through the owners manual. The built-in jam protection for the sun roof will force it all of the way open and will keep opening back up all of the way when you try to close it until the “jam” is removed. I recommend visually inspecting the tracks for debris and try cleaning/lubricating them and then see if the sun roof will close properly.

v/r

Connor
Canaust is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
CAtC12
Scion tC 2G Aero & Exterior
1
03-16-2015 07:29 AM
boxmobile
Introduction Forum
1
03-07-2015 02:54 AM
Kiwibox
Scion tC 1G Owners Lounge
0
12-15-2014 09:46 PM
umnitza
Exclusive Sponsored Sales
3
12-01-2014 06:26 PM


Thread Tools
Search this Thread
Quick Reply: Ipod/Sun roof issue 2006 tC


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.