Notices
Scion tC 1G Forced Induction
Turbo and supercharger applications...

Loud Squeal after 5k RPMs and 5-6 PSI boost

Old 08-18-2007, 04:50 PM
  #1  
Senior Member
10 Year Member
5 Year Member
SL Member
Scinergy
Thread Starter
 
kikcaffine's Avatar
 
Join Date: Mar 2005
Location: Norcross
Posts: 1,744
Default Loud Squeal after 5k RPMs and 5-6 PSI boost

Anyone know what could be causing this on the factory supercharger w/ a 9.5 pulley? It was puffing white smoke for a little while then it stopped now it makes a god aweful squealing/ buzzing noise and it wont boost over 5 pounds. Anyone know what it could be? I dont see any dust anywhere on my alternator or anything..... Its a goodyear gatorback belt that looks to be in perfect condition.
kikcaffine is offline  
Old 08-18-2007, 05:10 PM
  #2  
Senior Member
10 Year Member
5 Year Member
SL Member
Team ScioNRG
 
Simplyscion's Avatar
 
Join Date: May 2004
Location: Smithtown Scion (NY)
Posts: 3,789
Default

you are 100% having belt slippage problems...get a new belt
Simplyscion is offline  
Old 08-18-2007, 05:14 PM
  #3  
Senior Member
10 Year Member
5 Year Member
SL Member
Scinergy
Thread Starter
 
kikcaffine's Avatar
 
Join Date: Mar 2005
Location: Norcross
Posts: 1,744
Default

Oh ok, I have a gates but its the rite part number but it seems too small and doesnt fit rite. Will it hurt anything if i spray some of that belt dressing stuff on it until I can get it fixed tomorrow?
kikcaffine is offline  
Old 08-18-2007, 05:38 PM
  #4  
Senior Member
10 Year Member
5 Year Member
SL Member
Team ScioNRG
 
Simplyscion's Avatar
 
Join Date: May 2004
Location: Smithtown Scion (NY)
Posts: 3,789
Default

Originally Posted by kikcaffine
Oh ok, I have a gates but its the rite part number but it seems too small and doesnt fit rite. Will it hurt anything if i spray some of that belt dressing stuff on it until I can get it fixed tomorrow?
yea, it will be fine. Plus with the belt dressing, you should pick up another lb of boost or so due to the slippage.
Simplyscion is offline  
Old 08-20-2007, 05:14 AM
  #5  
Senior Member
5 Year Member
SL Member
 
Join Date: May 2006
Posts: 661
Default

dude didnt we just have this conversation in ur other thread bout it being slippage lol
hotwheelsrs1 is offline  
Old 08-20-2007, 06:38 PM
  #6  
Senior Member
10 Year Member
5 Year Member
SL Member
Scinergy
Thread Starter
 
kikcaffine's Avatar
 
Join Date: Mar 2005
Location: Norcross
Posts: 1,744
Default

Maybe, It was a different thing though!!!! I got my gates belt in now, the issue with the other post was that I had the Gauge tapped off the vac line from the BPV not the Vac line that goes into the throttle body.
kikcaffine is offline  
Old 03-05-2010, 11:45 PM
  #7  
Senior Member
5 Year Member
SL Member
 
Join Date: May 2008
Location: tustin
Posts: 460
Default

So if the belt squeals it means its slipping?
ProMark is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
Mdangelo
Scion tC 1G Owners Lounge
4
06-07-2015 07:15 PM
Joe_Dezod
Scion tC 1G Forced Induction
152
05-23-2013 08:59 PM
06tcflintmica
Scion tC 1G Drivetrain & Power
8
07-05-2006 04:53 PM
Phlame217
Scion tC 1G Drivetrain & Power
9
06-21-2006 07:02 AM
rockettc
Scion tC 1G Drivetrain & Power
18
05-26-2005 11:38 AM


Thread Tools
Search this Thread
Quick Reply: Loud Squeal after 5k RPMs and 5-6 PSI boost


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.