MAF woes - Scionlife.com


Scion xA Owners Lounge
2004-2006.5 [NCP61]

Reply
 
 
 
Thread Tools Search this Thread
Old 05-17-2017, 03:45 AM   #1
Junior Member
Thread Starter
 
Join Date: May 2017
Posts: 4
Default MAF woes

Hey everyone!
This is my first post. I've run into a conundrum.
2004 xa
1.5L 1497cc GAS MFI type 1NZFE.
Friends daughter was running several times without a gas cap and of course throwing trouble codes.
Replaced cap, smoked the car and found a major leak around the VVT solenoid by the front (pass side) of the engine.

Initially, this is what we got:
P0101: Mass or Volume Air Flow Circuit Range/Performance Problem
P0102: Mass or Volume Air Flow Circuit Low Input
P0113: Intake Air Temperature Circuit High Input
P0441: Evaporative Emission Control System Incorrect Purge Flow
P0442: Evaporative Emission Control System Leak Detected (small leak)
P0446: Evaporative Emission Control System Vent Control Circuit

After fixing the leak we found that the long term trim was of the charts (~40%) but everything else seemed fine.
Checked fuel pressure and it was about nothing.
Assumed the pump got knackered, compensating.
Replaced fuel pump and MAF with a cheapo off eBay.
No joy.
It WILL start now, but dies out after about 20-30 seconds.
So, replaced MAF with genuine Denso.
No joy.
This is what I'm getting now:
P0102 MAF circuit low input (current)
P0103 Intake air temp circuit high (current)
P0101 MAF or volume circuit range/performance problem (pending)

Getting the MAF code makes me wonder if there's a harness issue, but the performance doesn't change with it connected or not.
It's got to be a fuel issue somewhere b/c it runs just fine when shooting it with starting fluid.

Any input would be greatly appreciated!

Thanks in advance, I hope to be able to give back to the forum in the future!
LBC28715 is offline   Reply With Quote
Old 05-17-2017, 03:49 AM   #2
Junior Member
Thread Starter
 
Join Date: May 2017
Posts: 4
Default

I'll also add that, before changing the fuel pump, it wouldn't start at all.
Now, it starts, but dies quickly after.
I may try blowing the lines out, tomorrow.
LBC28715 is offline   Reply With Quote
Old 05-18-2017, 01:07 AM   #3
Junior Member
Thread Starter
 
Join Date: May 2017
Posts: 4
Default

No ideas at all?
LBC28715 is offline   Reply With Quote
 
 
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off



All times are GMT. The time now is 06:17 PM.