Notices
Scion xA/xB 1st-Gen Drivetrain & Power Engine and transmission discussions...

A bit of a sputter on acceleration in 2005 xA..

Old 03-29-2019, 03:29 PM
  #1  
Junior Member
Thread Starter
 
xellex727's Avatar
 
Join Date: Mar 2019
Location: Tampa, Florida
Posts: 3
Default A bit of a sputter on acceleration in 2005 xA..

Hey guys, new to the forum.
I have a 2005 Scion xA manual and I am having some sputtering on acceleration. No loss of power, no rough idle or anything else.
I just had a tune up and my plugs and wires replaced. Other than that is runs great.

Any ideas?

*Moved to Correct Forum by Administrator

Sticky Where to Post Your Question

Sticky How To Advanced Search SL (Scion Life)

_______________________________

Last edited by MR_LUV; 03-29-2019 at 06:31 PM. Reason: Moved to Correct Forum by Administrator
xellex727 is offline  
Old 03-29-2019, 04:01 PM
  #2  
Moderator
10 Year Member
5 Year Member
SL Member
Moderator
 
Join Date: Aug 2006
Posts: 351
Default

Was it acting the same way before you got the tune-up and there are no plug wires to be replaced...do you mean coil packs? If it wasn't doing it prior to the tune-up I would say there is an issue with the way the plugs were gapped...
MileHightC is offline  
Old 03-29-2019, 04:17 PM
  #3  
Junior Member
Thread Starter
 
xellex727's Avatar
 
Join Date: Mar 2019
Location: Tampa, Florida
Posts: 3
Default

Sorry, yeah I meant coil packs. It was doing it prior to the tune-up but it is way better now.
xellex727 is offline  
Old 03-29-2019, 11:02 PM
  #4  
Senior Member
10 Year Member
5 Year Member
SL Member

 
2stroked's Avatar
 
Join Date: Jun 2007
Location: Rochester, New York
Posts: 113
Default

Originally Posted by xellex727 View Post
Sorry, yeah I meant coil packs. It was doing it prior to the tune-up but it is way better now.
What brand of Coli Packs did you install? Many of the aftermarket units are of questionable quality.
2stroked is offline  
Old 05-14-2019, 07:10 AM
  #5  
Senior Member
10 Year Member
5 Year Member
SL Member
 
Join Date: Dec 2004
Posts: 125
Default

Just in case, check all air hoses from the filter box for a loose one.
adorable is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
halweh99
Scion tC 1G Drivetrain & Power
2
08-11-2017 06:31 AM
AcidSunsine
Scion tC 1G Drivetrain & Power
1
05-01-2017 12:41 PM
Bcwild
Scion FR-S Drivetrain & Power
0
06-11-2016 07:16 PM
kidwolf908
Scion tC 1G Drivetrain & Power
5
01-08-2008 09:27 PM
stankubrick
Scion xA/xB 1st-Gen Wheel & Tire
8
10-16-2003 10:38 AM


Thread Tools
Search this Thread
Quick Reply: A bit of a sputter on acceleration in 2005 xA..


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.