Notices
Scion tC 1G Forced Induction
Turbo and supercharger applications...

Remove Primary o2 Sensor - Always Open Loop???????

Old 10-30-2008, 02:16 PM
  #21  
Senior Member
5 Year Member
SL Member
 
Join Date: May 2005
Location: philly
Posts: 476
Default

i've tested this before and it works. like Ace83 said, just make sure you tune it or else it'll just dump fuel.


one other thing, if you decide to disconnect the primary O2 sensor connection, make sure you also physically unscrew it from the exhaust manifold or else it will permanently damage the sensor since it won't be "warmed up" for use.


FYI there is more info on this thread as it was discussed before: https://www.scionlife.com/forums/viewtopic.php?t=149527



Originally Posted by thendawg
when i ran mine without it pulled alot of timing according to the scanner i was using - anywhere between 10-20* based on rpm during acceleration - how did you compensate for this - no piggyback i know of can advance ign timing
e-manage ULTIMATE is the only piggyback currently available capable of advancing ignition timing. i wish the AEM FIC could advance timing instead of just retarding it.
tuffCookie is offline  
Old 10-30-2008, 03:14 PM
  #22  
Senior Member
10 Year Member
5 Year Member
SL Member
Thread Starter
iTrader: (1)
 
johnhawkins's Avatar
 
Join Date: Oct 2008
Location: Buffalo, NY
Posts: 1,100
Default

Thanks everyone for your input!!!! This gives MUCH hope/insight for people who said the neo cant be used successfullly tune the tC. AWESOME!!!!
johnhawkins is offline  
Old 10-30-2008, 10:56 PM
  #23  
Senior Member
10 Year Member
5 Year Member
SL Member

 
chintastictc's Avatar
 
Join Date: Apr 2008
Location: Valley Stream, NY
Posts: 1,049
Default

Originally Posted by johnhawkins
Thanks everyone for your input!!!! This gives MUCH hope/insight for people who said the neo cant be used successfullly tune the tC. AWESOME!!!!
it cant....











lol im just messin lol im bored at work
chintastictc is offline  
Old 10-31-2008, 05:17 PM
  #24  
Senior Member
5 Year Member

SL Member
 
Streeter's Avatar
 
Join Date: Aug 2004
Location: Minneapolis
Posts: 1,629
Default

Yes, I unknowingly ran my car for a long time with a broken primary o2 sensor. Fuel economy was total crap when I went into boost - as they said your tune has to be bang on. Limp mode is when the car won't go over like 2k rpms or faster than 20mph (guessing the exact numbers - it's been a long time since I was in limp mode.) Usually that will happen is there is something wrong with your MAF sensor.
Streeter is offline  
Old 11-13-2008, 07:16 PM
  #25  
Senior Member
10 Year Member
5 Year Member
SL Member
Thread Starter
iTrader: (1)
 
johnhawkins's Avatar
 
Join Date: Oct 2008
Location: Buffalo, NY
Posts: 1,100
Default

So lets say I disconenect the primary o2 sensor and I have the 440cc injectors.

Even if Im at 6psi it will still run rich at all RPM when in OP3 (open loop 3)?????
So when tuning with the Neo I will actually be subtracting fuel???
johnhawkins is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
yhwhdesign
Scion tC 1G Drivetrain & Power
3
03-04-2018 06:59 AM
prescottn
Scion iM Discussion Lounge
6
10-08-2015 05:31 PM
prescottn
Scion iM Discussion Lounge
0
09-22-2015 01:30 PM
Threequalseven
Scion xD Owner's Lounge
3
08-26-2015 04:24 PM
StxArOne
Scion xA Aero & Exterior
1
08-21-2015 06:44 PM


Thread Tools
Search this Thread
Quick Reply: Remove Primary o2 Sensor - Always Open Loop???????


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.