Go Back  Scionlife.com > Scion xD > Scion xD Owner's Lounge > Scion xD Drivetrain & Power
Reload this Page >

Another XD Automatic Transmission Problem (No Gear Selection Possible)

Notices
Scion xD Drivetrain & Power Engine and transmission discussions...

Another XD Automatic Transmission Problem (No Gear Selection Possible)

Old 11-18-2016, 03:29 AM
  #1  
Junior Member
5 Year Member
Thread Starter
 
Join Date: Jul 2011
Posts: 12
Default Another XD Automatic Transmission Problem (No Gear Selection Possible)

Wife's car....she said it made some loud noise driving home and then when she got home it would not go into any gear position (P/R/N/D/1/2) and was stuck in the driveway. I found the gear selection cable had come off the gear selection shifter in the console so I popped it back on and it shifted back into Park and I could now start it up. Thinking it was fixed I put it into Reverse and it did nothing. I tried to put it into Neutral/Drive but the gear selector would not move any further than Reverse. I jacked up the car so both front wheels were off the ground and started up car and tried to move the shift lever arm on the transmission by hand but could not move it.

Car has 165k miles and I have drained/changed the tranny fluid a few times, usually it is about 2 quarts that drains out. Used Toyota recommended ATF (expensive as hell).

Has anybody got any ideas or suggestions of anything else I can check or does this just sound like the tranny is busted? How difficult it is to pull that tranny out and replace it with a rebuilt or used one? I have experience with older cars and manual transmissions but have not really messed too much with newer cars.

TIA....
dsefcik is offline  
Old 11-19-2016, 12:25 AM
  #2  
Junior Member
5 Year Member
Thread Starter
 
Join Date: Jul 2011
Posts: 12
Default

So I pulled the "Transmission Wire" connector off of the transmission (above the park/neutral connector) and turned the ignition on, pressed the brakes and it cycled thru all gears normally! Turned it all off and reconnected the electrical connector and drove it around, seemed normal but now I am afraid to trust it without knowing why this happened. Anybody have any idea what would cause the transmission to get "stuck" in some gear mode and by disconnecting the transmission wire it fixed it?
dsefcik is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.