Multiple Electrical Issues, Won't Shift Out of Park - Scionlife.com

Go Back  Scionlife.com > Scion xD > Scion xD Owner's Lounge
Reload this Page >

Multiple Electrical Issues, Won't Shift Out of Park

Notices
Scion xD Owner's Lounge
2008-2010 [ZSP110]

Multiple Electrical Issues, Won't Shift Out of Park

Old 11-10-2016, 12:47 PM
  #1  
Junior Member
5 Year Member
Thread Starter
 
Join Date: Dec 2012
Posts: 2
Default Multiple Electrical Issues, Won't Shift Out of Park

I just ran into a weird problem where the car would start and run normally, but many of the dash warning lights were on, the AC wouldn't run, the rear brake lights wouldn't work, the radio wouldn't work. etc. Couldn't shift out of gear. I checked every fuse there was, every relay there was, and still same problem. UNTIL I found that the fused positive terminal link had a crack in one side of the trace. I replaced the positive terminal fuse link for 13.95 from Toyota dealer and wallah... Problem Solved.
rascol is offline  
Old 03-31-2017, 07:44 PM
  #2  
Junior Member
 
Join Date: Jul 2013
Posts: 1
Default

I'm have the same issues with my 2011 xD and have had it at the dealer to diagnose. They finally want to replace the ECU for $1200 but I opted to get a remanufactured ECU. After replacing the ECU it is still doing the same thing. Just wondering if you can provide any info on the location of fuseable link that you replaced.
Thanks
lpdobbs is offline  

Thread Tools
Search this Thread

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.