Notices
Scion tC 1G Drivetrain & Power Engine and transmission discussions...

Help! Throwing CEL Codes P0113,P0441,P0455

Old 09-13-2011, 02:08 AM
  #1  
Senior Member
5 Year Member
SL Member
Thread Starter
 
Join Date: Sep 2004
Location: Pico
Posts: 196
Default Help! Throwing CEL Codes P0113,P0441,P0455

P0113 - Intake air temperature circuit high input
P0441 - Evaporative emission control system incorrect purge flow
P0455 - Evaporative emission control system leak detected (gross)

Just the other day my Gf's CEL came on... These are the codes.
The car is an 06 tC 5 speed coming up on about 100,000 miles with a K&N Cold air intake.

Can anyone help with suggestions on what I could start checking or replacing.

For additional info, about 2 weeks ago we made a 400 mile trip up north and before the trip i noticed a low bumpy idle, so i bought MAF cleaner, and cleaned the MAF. The car idled awesome and the car was no problem until recently. The car feels like it drives fine, I haven't noticed it myself yet but my GF mentioned it stalled a couple of times on her today and had a low choppy idle.

Thanks for the help.
the_butcher is offline  
Old 09-13-2011, 11:12 PM
  #2  
Senior Member
5 Year Member
SL Member
 
mrexotica's Avatar
 
Join Date: Mar 2007
Posts: 774
Default

Search the Internet for the detailed explanations for the codes.

With evap codes, it could be as simple as a $25 gas cap. Or it could be expensive.
mrexotica is offline  
Old 09-14-2011, 10:00 PM
  #3  
Senior Member
10 Year Member
5 Year Member
SL Member
iTrader: (2)
 
myr6goesfast's Avatar
 
Join Date: Aug 2008
Location: Cali
Posts: 481
Default

I'm getting the P0441 & P0455 codes and I'm 99% sure it's my gas cap... it doesn't lock. Just sitting over the opening.
myr6goesfast is offline  
Old 09-14-2011, 11:34 PM
  #4  
Senior Member
5 Year Member
SL Member
 
mrexotica's Avatar
 
Join Date: Mar 2007
Posts: 774
Default

Very clearly, you need a new gas cap...
mrexotica is offline  
Old 09-15-2011, 06:57 AM
  #5  
Senior Member
5 Year Member
SL Member
Thread Starter
 
Join Date: Sep 2004
Location: Pico
Posts: 196
Default

Sweet, going to change over the K&N CAI to stock and get a new gas cap.. sucks Cause this is the 2nd gas cap in the past 4-5 years
the_butcher is offline  
Old 09-15-2011, 09:02 AM
  #6  
Senior Member
10 Year Member
5 Year Member
SL Member

 
Join Date: Jul 2004
Location: Michigan
Posts: 3,900
Default

Originally Posted by the_butcher View Post
Sweet, going to change over the K&N CAI to stock and get a new gas cap.. sucks Cause this is the 2nd gas cap in the past 4-5 years
i've heard this before.. on my old car, i had to replace those gas caps every 2-3 years. The seal would age, flatten out, and start leaking.

You might also want to check the fuel filler neck lip for any corrosion where the gas cap gasket seals against the lip. Any corrosion there would cause a leak against the gas cap gasket. But if you find any corrosion then stuff a rag into the filler neck and use a green scrubby to make it clean again. the rag is there to stop anything getting into your gas tank when you scrub off any corrosion from the filler lip. definitely dont want bad stuff in the gas tank

about that code of "intake air temp" that sounds like the MAF sensor alright.. it has the IAT (idle air temp) on the side, that amber bulb looking thing is the IAT. The MAF is the two dental floss wires down the tube. If you're using CRC's MAF sensor cleaner and waiting for it to dry before reinstalling, then I'd say that it's clean, and you have a bad MAF sensor.. Try cleaning it again one more time, clear the code, and see if that IAT code comes back.
sciontc_mich is offline  
Old 09-15-2011, 04:46 PM
  #7  
Senior Member
SL Member
 
Join Date: May 2008
Location: WI
Posts: 201
Default

As with the MAF sensor going bad; did she recently do anything electrical around / with the battery? I touched a socket wrench off the positive terminal to the MAF sensor area by accident, spark! MAF died and rough idle. Replaced it (~$80) and works. didn't measure CEL codes though cuz I knew what I did wrong lol.
fongyz is offline  
Old 09-16-2011, 01:23 AM
  #8  
Senior Member
5 Year Member
SL Member
 
mrexotica's Avatar
 
Join Date: Mar 2007
Posts: 774
Default

Originally Posted by the_butcher View Post
Sweet, going to change over the K&N CAI to stock and get a new gas cap.. sucks Cause this is the 2nd gas cap in the past 4-5 years
K&N is reputable. Do one thing at a time.
mrexotica is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
MeDizzy
Scion xA Owners Lounge
10
10-08-2015 03:31 PM
Gigs
Scion tC 1G Forced Induction
1
09-15-2015 03:54 AM
mw1957
Scion xA/xB 1st-Gen Drivetrain & Power
0
07-28-2015 06:04 AM
mw1957
Scion iA Discussion Lounge
0
07-28-2015 05:31 AM
rancur3p1c
Scion tC 1G Drivetrain & Power
1
07-12-2015 07:59 PM


Thread Tools
Search this Thread
Quick Reply: Help! Throwing CEL Codes P0113,P0441,P0455


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.