Notices
Scion xA/xB 1st-Gen Drivetrain & Power Engine and transmission discussions...

P0171 Nightmare

Old 10-02-2018, 04:12 AM
  #1  
Member
SL Member
Thread Starter
 
Join Date: Jan 2015
Posts: 25
Default P0171 Nightmare

So I feel like I've read everything there is on the subject over the internet. Long story short, gradually I've been getting an intermittent P0171 Check Engine Code with the VSC and traction lights. It would happen while the car would be idling at a stop light then later go away. I do experience weird idles sometimes, for example, sometimes if I have AC blasting at a stop sign my engine might dip to like 600-700 rpm before shooting back up to 1-1.2k. The car has never died on me. Furthermore, sometimes when I floor it I notice a little lag (1-2 seconds) before I feel like the engine really pull. I've replaced the upstream O2 sensor as well as the MAF sensor. Next course of action I believe I will replace the fuel injectors. I've checked for obvious air leaks but I see nothing. Any other ideas?

_________

Last edited by MR_LUV; 02-10-2019 at 03:41 PM.
eatcrispycreme2 is offline  
Old 10-09-2018, 02:27 AM
  #2  
Member
SL Member
Thread Starter
 
Join Date: Jan 2015
Posts: 25
Default

Well, I managed to fix the code. I went ahead to change out the injectors and that seems to have been the issue. I've since put on another 150 miles after resetting the code and it hasn't come back. Usually the code would be coming back within ten miles. Hope this helps someone.
eatcrispycreme2 is offline  
Old 10-09-2018, 09:11 PM
  #3  
Moderator
10 Year Member
5 Year Member
SL Member
Moderator
 
Join Date: Aug 2006
Posts: 351
Default

Keep us posted as to whether or not the codes come back as this might prove to be a fix for someone else farther down the road, so it's always nice when people take the time to list fixes they've found.
MileHightC is offline  
Old 10-12-2018, 03:27 PM
  #4  
Member
SL Member
 
jimmyess333's Avatar
 
Join Date: Sep 2018
Posts: 51
Default

I know it's a different car but still a Toyota.
I've been battling this code on my sister's car for years.
So far in the last 4 years I've replaced all the vacuum lines, PCV valve, intake gasket, TB gasket, 02 sensors, injectors, fuel pump, engine temp sensor.
Still the same symptoms and code as yours persist.
She's gone to 2 mechanics and they couldn't find the problem.

At one point it got worse and I changed the air temp sensor on the airbox.
It ran much better but the original P0171 code and hesitation persists.



jimmyess333 is offline  
Old 11-28-2018, 06:18 AM
  #5  
Member
SL Member
Thread Starter
 
Join Date: Jan 2015
Posts: 25
Default

Well the code is back. I'm thinking it may have something to do with fuel delivery because after replacing the injectors I didn't seem to get any problems. I also replaced the intake manifold gasket for the heck of it as I heard these were common problems on our cars. Still the code comes back unfortunately. I have recently noticed a new issue however. In 1st and 2nd gear, after clearing any fault codes, the car will hesitate on acceleration and buck a little bit before it gets going. 3rd, 4th, and 5th gear no problems. When the CEL goes back on, this won't happen at these lower gears. The system is obviously comprnsating for the shortcomings correctly but I'm still confused as far as what it means.
eatcrispycreme2 is offline  
Old 12-11-2018, 03:32 AM
  #6  
Member
SL Member
Thread Starter
 
Join Date: Jan 2015
Posts: 25
Default

Update: I've now replaced the fuel pump. I feel like this has solved the problem. There is no more hesitation at low rpm's so far. It's only been a week however. I will continue to update the thread.
eatcrispycreme2 is offline  
Old 02-10-2019, 01:53 PM
  #7  
Junior Member
 
Join Date: Feb 2019
Posts: 1
Default

0171 is a lean fuel mixture - yes, injectors will cause that, as will weak fuel pump, filthy intake valves, or even a clogged fuel filter. Change the filter. Then start with Techron, then move to the full BG Products treatment, then swap injectors (unless you find low pressure on the fuel rail, in which case pop in a new fuel pump)

When you pair that with a 0172 (rich fuel mixture) you've got a dead cylinder and need a motor. (1995 Toyota 4Runner, blew the motor twice. FPOS 3.0)

- Will England, Fine New Guy to the Forums
2005 Scion xB (Monday - son's car)
wingland is offline  
Old 02-11-2019, 01:29 PM
  #8  
Senior Member
SL Member
 
Join Date: Oct 2014
Posts: 142
Default

Other things that might cause a lean condition:

Bad fuel pump relay. Air intake leak. PCV system leak.
62Fender is offline  
Old 02-14-2019, 03:35 PM
  #9  
Member
SL Member
Thread Starter
 
Join Date: Jan 2015
Posts: 25
Default

I've replaced injectors, fuel pump, fuel filter. I can't seem to find any air leaks in the intake or PCV. I am going to check the fuel pump relay tho. Code still comes back but only after driving a good amount (400 miles or so). Luckily, I can still pass smog after resetting it and driving 50 miles or so since the code doesn't come back immediately. I notice no symptoms other than sometimes when I floor it I lose some power right at the start. Makes me think air leak but I can't locate anything.
eatcrispycreme2 is offline  
Old 02-15-2019, 01:47 AM
  #10  
Administrator
10 Year Member
5 Year Member
SL Member
Administrator

 
MR_LUV's Avatar
 
Join Date: Dec 2007
Location: State of Confusion: CA
Posts: 1,884
Default


This is all I can find on your problem.

Hope it Helps,

MR LUV

MR_LUV is offline  
Old 03-31-2019, 08:13 AM
  #11  
Member
SL Member
Thread Starter
 
Join Date: Jan 2015
Posts: 25
Default

Wanted to update everyone. I believe the issue is fixed. I took out my new MAF sensor that I had already replaced and sprayed it with cleaner till it was soaking.
Reset the code and have driven 500 miles since and still no code. It seems to have been the MAF all along. Cold start accelerations still hesitate slightly but no other issues.

_____________

Last edited by MR_LUV; 03-31-2019 at 02:24 PM.
eatcrispycreme2 is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
ShockTherapy
Scion xA/xB 1st-Gen Drivetrain & Power
14
06-29-2009 06:58 AM
semaJames
Scion tC 1G Drivetrain & Power
13
12-07-2007 04:10 AM
Bull
Maintenance & Car Care
6
02-26-2007 05:13 AM
jct
Maintenance & Car Care
4
10-03-2006 12:42 AM
magyver
Scion tC 1G Drivetrain & Power
4
06-24-2006 08:16 AM


Thread Tools
Search this Thread
Quick Reply: P0171 Nightmare


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.