Notices
Scion tC 1G Drivetrain & Power Engine and transmission discussions...

Acceleration issues..

Old 04-13-2019, 11:21 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Apr 2019
Posts: 1
Unhappy Acceleration issues..

I have been having an annoying problem recently. whenever I am cruising around town and I want to punch it, the engine revs up nice and fast but it doesn't move any faster unless I really really ease into it.
I also have just generally bad acceleration issues even for a l-4. I have a stock 2008 tC automatic with 153k miles, only have driven it for 6k miles my self, problems been present since day one.

Does anyone have any crazy ideas about what's wrong?

________

Last edited by MR_LUV; 04-19-2019 at 04:46 AM.
lorddjj is offline  
Old 04-19-2019, 04:30 AM
  #2  
Member
SL Member
 
dogg's Avatar
 
Join Date: Dec 2018
Location: Central Florida
Posts: 32
Default

same thing here since i owned it from brand new, 2008...think it has to do with the trans via the engine module, dependent on which gear the trans is in, first mostly for me...i know exactly what you mean...starting off normally, then have to punch it to get the hell out of the way of whatever, and the damn thing boggs down like its not going any where, like the brakes have been applied, even though the rpms are revved up...not a comfortable feeling...seems to be a design flaw to me..too much input all at once for the fly by wire accelerator system to handle....whatcha gonna do??? ill sue if i have a major incident because of it...
dogg is offline  
Old 05-04-2019, 02:28 AM
  #3  
Senior Member
10 Year Member
5 Year Member
Scikotics
SL Member

 
xdejablu3x's Avatar
 
Join Date: Nov 2006
Location: Poser City, Texas
Posts: 2,203
Default

I thought the whole point of this is the drive by wire doing its job for fuel economy or are you guys talking about something?
xdejablu3x is offline  
Old 05-07-2019, 01:20 AM
  #4  
Member
SL Member
 
dogg's Avatar
 
Join Date: Dec 2018
Location: Central Florida
Posts: 32
Default

Originally Posted by xdejablu3x View Post
I thought the whole point of this is the drive by wire doing its job for fuel economy or are you guys talking about something?

dont think the fby has anything to do with economy...only easier and cheaper than running a mechanical linkage setup (maybe a little of both???)...ill try to get the issue recorded on my gopro...then all can see and opine!!!
dogg is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
kgoerbig
Scion xB 1st-Gen Owners Lounge
3
04-17-2015 12:40 AM
ChickenAdobo
Scion xA/xB 1st-Gen Wheel & Tire
6
10-05-2004 10:55 PM
tstalion79
Scion tC 1G Owners Lounge
23
08-01-2004 02:45 PM
nethack4ever
Maintenance & Car Care
7
07-23-2004 02:20 AM
stankubrick
Scion xA/xB 1st-Gen Wheel & Tire
8
10-16-2003 10:38 AM


Thread Tools
Search this Thread
Quick Reply: Acceleration issues..


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.