Notices
Scion tC 1G Forced Induction
Turbo and supercharger applications...

DIY-AEM F/IC-now with 2-Step launch control

Old 05-01-2010, 02:36 PM
  #141  
Banned
10 Year Member
5 Year Member
SL Member

 
Join Date: Nov 2007
Location: Germantown, MD
Posts: 2,894
Default

Originally Posted by crush02342002 View Post
I think the specs for the fic say 1amp max from the 12v switch...so 1amp will do
ill get a 1 amp then ill also run a 1 amp fuse? if they make those lol
cburglb34 is offline  
Old 05-01-2010, 02:45 PM
  #142  
Senior Member
10 Year Member

5 Year Member
Trader
SL Member
Thread Starter
iTrader: (2)
 
crush02342002's Avatar
 
Join Date: Feb 2008
Location: Houston, Tx
Posts: 11,271
Default

they dont make em in a blade style...that iv seen anyways but i think iv seen em in a glass sae fuse (older cars from the 80s used em)
crush02342002 is offline  
Old 05-01-2010, 02:47 PM
  #143  
Senior Member
10 Year Member

5 Year Member
Trader
SL Member
Thread Starter
iTrader: (2)
 
crush02342002's Avatar
 
Join Date: Feb 2008
Location: Houston, Tx
Posts: 11,271
Default

just checked but you can get a 1amp blade style (standard not mini or maxi). they are just hard to find.
crush02342002 is offline  
Old 05-01-2010, 02:47 PM
  #144  
Banned
10 Year Member
5 Year Member
SL Member

 
Join Date: Nov 2007
Location: Germantown, MD
Posts: 2,894
Default

Originally Posted by crush02342002 View Post
they dont make em in a blade style...that iv seen anyways but i think iv seen em in a glass sae fuse (older cars from the 80s used em)

ok cool ill just get a switch first worry of fuse later...this is pretty neat stuff here i actually like that it doesnt build boos tthat way i can launch at w.e rpm i want and not worry too much bout spinning because of boost...
cburglb34 is offline  
Old 05-01-2010, 03:08 PM
  #145  
Senior Member
10 Year Member

5 Year Member
Trader
SL Member
Thread Starter
iTrader: (2)
 
crush02342002's Avatar
 
Join Date: Feb 2008
Location: Houston, Tx
Posts: 11,271
Default

just a tip though, i noticed that if i stay on 2step/rev limiter too long the ecu goes on the frits and acts like the car is stuck in 2step mode. Its not the fic thats doing it from what i can tell cause the car will go back to normal as soon as the cel stops blinking.
crush02342002 is offline  
Old 05-01-2010, 03:35 PM
  #146  
Banned
10 Year Member
5 Year Member
SL Member

 
Join Date: Nov 2007
Location: Germantown, MD
Posts: 2,894
Default

Originally Posted by crush02342002 View Post
just a tip though, i noticed that if i stay on 2step/rev limiter too long the ecu goes on the frits and acts like the car is stuck in 2step mode. Its not the fic thats doing it from what i can tell cause the car will go back to normal as soon as the cel stops blinking.

havent had this issue yet....and also ive only gotten the blinking cel once that was the first time i used the 2step now it just stays on idk what the code it nor do i care car aint in limp lol
cburglb34 is offline  
Old 05-01-2010, 05:11 PM
  #147  
Banned
10 Year Member
5 Year Member
SL Member

 
Join Date: Nov 2007
Location: Germantown, MD
Posts: 2,894
Default

OMG videos!!!

http://www.youtube.com/watch?v=vv2gKY6LFNM

http://www.youtube.com/watch?v=2YmAS2o_rNs


both vids same settings... usually it sounds like vid 2.... but sometimes just like vid 1
cburglb34 is offline  
Old 05-01-2010, 07:06 PM
  #148  
Senior Member
10 Year Member

5 Year Member
Trader
SL Member
Thread Starter
iTrader: (2)
 
crush02342002's Avatar
 
Join Date: Feb 2008
Location: Houston, Tx
Posts: 11,271
Default

Originally Posted by cburglb34 View Post
havent had this issue yet....and also ive only gotten the blinking cel once that was the first time i used the 2step now it just stays on idk what the code it nor do i care car aint in limp lol
hmmm...could be my wires or relay maybe...idk..havnt played with it since the last vid i put out. good job though mang!!
crush02342002 is offline  
Old 05-01-2010, 10:49 PM
  #149  
Senior Member
10 Year Member
5 Year Member
Team ScionEyed
SL Member
 
weezyfbayba's Avatar
 
Join Date: Mar 2009
Posts: 4,356
Default

lol it sounds ok when i had aem ems ____ sounded like shotguns going off lol
weezyfbayba is offline  
Old 05-12-2010, 05:00 PM
  #150  
Banned
SL Member
 
Join Date: Jan 2010
Posts: 270
Default

it sucks that it wont build up any boost
gwopsta is offline  
Old 05-12-2010, 05:09 PM
  #151  
Senior Member
5 Year Member
SL Member
iTrader: (5)

 
Thorium06's Avatar
 
Join Date: Nov 2007
Location: Lone Tree/ Fort Collins
Posts: 1,019
Default

well so how bout that anti lag next? lol
Thorium06 is offline  
Old 05-13-2010, 02:46 AM
  #152  
Senior Member
10 Year Member

5 Year Member
Trader
SL Member
Thread Starter
iTrader: (2)
 
crush02342002's Avatar
 
Join Date: Feb 2008
Location: Houston, Tx
Posts: 11,271
Default

lulz...thats prolly last on my list of "to do". got too much going on right now. working 6 10's every other week, 4 10's on normal weeks. I love 3 days off but one of those days is for getting stupid crap done (bills, cleaning, shopping, ect). weekends i try my best to reserve for my little girl. nothing works out as planned though.
crush02342002 is offline  
Old 05-13-2010, 02:47 AM
  #153  
Senior Member
10 Year Member

5 Year Member
Trader
SL Member
Thread Starter
iTrader: (2)
 
crush02342002's Avatar
 
Join Date: Feb 2008
Location: Houston, Tx
Posts: 11,271
Default

I thought he said it built a small amount of boost?
crush02342002 is offline  
Old 05-13-2010, 03:15 AM
  #154  
Banned
10 Year Member
5 Year Member
SL Member

 
Join Date: Nov 2007
Location: Germantown, MD
Posts: 2,894
Default

2psi
cburglb34 is offline  
Old 06-27-2010, 09:53 AM
  #155  
Senior Member
5 Year Member
SL Member
 
maherdan82's Avatar
 
Join Date: Nov 2004
Location: Illinois
Posts: 144
Default

2psi is all I can boost with my wot box and the turbonetics kit. Still on stock mid pipe thoe. Hopefully 3in exhaust will help.
maherdan82 is offline  
Old 12-08-2011, 07:44 PM
  #156  
Junior Member
 
Join Date: Dec 2011
Posts: 2
Default

Hi,, AEM Fic wiring Diagram TSX K20A Japan CL7 ??

Thanks~

Last edited by MR_LUV; 10-31-2017 at 04:43 AM.
coke0sp is offline  
Old 08-02-2013, 02:22 AM
  #157  
Junior Member
 
Join Date: Aug 2013
Posts: 1
Default

hi, I signed up to ask a question about the aem 2 step setup you made, I have aem fic on a turbo car and I was just wondering if you thought to hook the relay up to the crank sensor instead of cutting the power to the coils? cutting signal to the crank sensor might make it a more random spark cut which might get more pop pop out the exhaust.

I was going to give it a go anyways, my fuse for the coils is also fuse for the fuel pump so I couldn't do that same way as in the thread
orangeute338 is offline  
Old 08-03-2013, 02:48 PM
  #158  
Junior Member
 
Join Date: Jun 2013
Posts: 23
Default

Nice write up!

Last edited by MR_LUV; 10-31-2017 at 04:45 AM.
somejace is offline  
Old 10-31-2017, 05:15 AM
  #159  
Administrator
10 Year Member
5 Year Member
SL Member
Administrator

 
MR_LUV's Avatar
 
Join Date: Dec 2007
Location: State of Confusion: CA
Posts: 1,883
Default

MR_LUV is offline  
Related Topics
Thread
Thread Starter
Forum
Replies
Last Post
my06tc
PPC: Engine / Drivetrain
10
06-25-2015 12:18 AM
JonathonK
Off-topic Cafe
1
04-03-2015 05:43 PM
RacerSpeed
Regional - Mid South: CLT Metro
0
03-19-2015 08:43 PM
carid
Exclusive Sponsored Sales
0
02-12-2015 11:54 AM


Thread Tools
Search this Thread
Quick Reply: DIY-AEM F/IC-now with 2-Step launch control


Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.