Notices
Scion xD Drivetrain & Power Engine and transmission discussions...

Please help car won't start and has no power

Old 08-02-2017, 07:01 PM
  #1  
Junior Member
Thread Starter
 
Join Date: Aug 2017
Posts: 1
Default Please help car won't start and has no power

My son has a 2008 Scion he drove it just fine parked it for a couple hours came back to get it, tried to start it, will not turn over, has no power to radio, interior lights, etc.

Does anyone have any ideas on what the problem could be any thoughts would be greatly appreciated

Last edited by MR_LUV; 03-28-2018 at 10:07 PM. Reason: Moved to Correct Forum by Moderator
Bobbyzeke is offline  
Old 08-07-2017, 10:46 PM
  #2  
Junior Member

 
Dano88ish's Avatar
 
Join Date: Aug 2015
Location: Las Vegas, Nevada
Posts: 5
Default Had the same issue with my 05 tC...

Originally Posted by Bobbyzeke View Post
My son has a 2008 scion he drove it just fine parked it for a couple hours came back to get it, tried to start it, will not turn over, has no power to radio, interior lights, etc does anyone have any ideas on what the problem could be any thoughts would be greatly appreciated
Hey, I had the same issue with my 2005 Scion tC... After messin around with a number of things... It ended up bein the battery ground cable that grounds to the body from the negative on the battery... I fixed it myself... You have to remove both positive and negative cables from battery... Remove battery... Remove the plate the battery sits on... There will be a smaller cable off of the negative grounded to the frame under the battery... Remove that... And the other thicker cable from the negative grounds to the engine behind the starter... I removed the starter to remove the ground bolt... I replaced the ground cable that goes from the negative to the frame under the battery, and reused the existin thicker cable that grounded to the engine... Both of the ground cables were super corroded down to the core, so Ima need to replace the thicker one ASAP! Anyway, I put everything back together, had power to the car and she started right up! I bought the ground cable from AutoZone for like $10.00... I recommend you get either the 15" long replacement cable or longer. I got the 15" one and it was barely just right... You might wanna get the longer one to have a little more slack to work with... I hope this helps you out... I've read countless threads on this forum where people have had the same issue as us, but nobody ended up comin back and sayin what the issue actually was... Do me and all of us a favor and come back to let us know if that fixed the issue for you as well... Good Luck!
Dano88ish is offline  

Thread Tools
Search this Thread

Contact Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.